Hi everyone,

We’ve now upgraded to v0.19.5 - this update includes the changes from v0.19.4, which we had not yet upgraded to. This is a relatively big one, and you can find details here:

v0.19.4

v0.19.5


Here are some of the user-facing highlights:

  • There is now a dropdown option to hide posts.

  • You can now view and delete all images you’ve previously uploaded.

  • Federation has been improved in a number of ways. It’s now possible to federate with Wordpress, Discourse, and NodeBB. Federation with Mastodon has been improved, and we should now be federated with more servers on that platform. Most posts to our communities should automatically receive a hashtag matching the community’s name (e.g., #startrek, #daystrominstitute, etc.). This is dependent on the poster’s home instance, though, so only posts from servers which are running v0.19.4 or higher will receive the hashtags.

  • There’s now a user setting to change how votes are displayed - you can see or hide upvotes, downvotes, score, upvote %, or none.


I’d also like to remind you that we have two alternative interfaces available:

Edit: We also have a wiki, which is open to users who feel inspired to develop resources for this community!


Finally, we remain eternally grateful to all users who are able to support startrek.website by contributing to our Patreon - your generosity helps to keep the lights on!


🖖 The Admin Team

  • Morgoon
    link
    fedilink
    English
    arrow-up
    6
    ·
    18 days ago

    May we continue to live long and prosper

  • klemptor
    link
    fedilink
    English
    arrow-up
    4
    ·
    18 days ago

    Thank you, thank you, thank youuuu!! 🖖🏻

  • data1701d
    link
    fedilink
    English
    arrow-up
    1
    ·
    18 days ago

    I’m excited at the update. However, I am experiencing a small issue. I use the i386 theme. However, the color scheme (and nothing else, like fonts or borders) has reverted from its usual blue to the default dark mode colors. I tried clearing my browser data to see if that would clear things up, but Shaka when the walls fell. I don’t know if this is an upstream issue (which is my guess) or something else, as I am inexperienced with Lemmy infrastructure.

    Otherwise, it’s all working fine. Thanks for your efforts, and glory to your house!

    • Value SubtractedOPMA
      link
      fedilink
      English
      arrow-up
      2
      ·
      edit-2
      17 days ago

      Have you checked your user settings? It’s possible that the update reverted your preference to the default. i386 should still be available.

      Never mind, I did some digging, and it looks like something has changed and/or is broken with the theme itself. I’ll keep an eye out for a possible solution.